The PlecoDict Beta Feedback Thread

A

Anonymous

Guest
#81
Just want to report some bugs with the latest version.

From time to time i get some chunk overload something message and have to soft reset. This didn't happen before.

It also seems to crash when i switch on input mode for penpower.

I had made quite a few flashcards with the last version and it worked fine. After i exported them and imported them to the new version a lot of words came up as invalid. It did help a lot to switch from unicode to the GB smt. (can't remember that number right now), but still quite a few comes up as invalid!

I find it quite tedious to import flashcard-files one by one, could it be made possible to just check of the ones i wanna import and import them in one go?

Also i usually choose the best explaination from either OX or ABC but now all my flascards are ABC. Just a bit annoying.

I run PlecoD on a TE, but i get the chunk overload on my gf's T5 as well.
 
#82
magnify . . more functionality

I love the idea of more choices being available when looking at an magnified font . . .

It is so much easier to tap on a character then select it!

you could 'copy to input field,' 'add to flashcards,' . . . umm well that is all I can think of but it would be fantastic to be able to do those two common tasks from the magnified font window.

Henry
 

mikelove

皇帝
Staff member
#83
Is there any particular pattern to the chunk overlock messages? Anything that you're usually doing when they occur? Do they usually happen after you've been using the dictionary for a while? If there's some particular thing that seems to cause it, try doing that same thing 16 times in a row (that particular number is important) and see if that brings about the error.

Are you referring to PenPower's input mode (the thing you enable/disable by tapping on the search button or whatever) or the "input field compatibility mode" in PlecoDict? Does the crash happen immediately after you switch on PenPower or does it happen the first time you try to draw a character with it? What version of PenPower is this? (it'll appear at the upper right corner of the PenPower control panel)

I'm afraid there's not a whole lot we can do about the flashcard mis-conversions - the import/export system really wasn't designed for moving flashcards between different versions of PlecoDict, it's designed mainly for importing fixed word lists (HSK, PCR, etc). One thing that might help is if you go through the exported data files and clean up any entries that you can - remove any bracketed traditional text and other punctuation from the character entries and see if that improves the situation.

Once we reach 1.0, we're committed to offering a much better flashcard upgrade system for any future incompatible versions, so you can create flashcards for that with a greater level of confidence, but there's a reason why we we put so many warning messages on the beta version...
 

mikelove

皇帝
Staff member
#84
A more powerful magnification screen would be a nice feature, yes - something like that was actually in our original design for PlecoDict 1.0, but we had to abandon it when things started taking longer than we expected. It's still on the list of things we'd like to add in the next major release, though.
 
A

Anonymous

Guest
#85
I tried to turn off Input field compability mode and see if i could provoke the bug again and it actually came up as soon as i turned it off. It says something like "Error message line 2621 Chunk overlocked".

Sorry i can't remember what it says cuz now i can't make it crash again! My version off Penpower is 2.0N

Maybe it fixed itself :) I'll write down the error message if it comes up again.

I realize i was on my own risk with the flashcards, just wanted to report it anyways since i wasn't sure if it was a bug.
 
#86
minor DIA-related problem I thought would disappear but is still there with beta2 : on the UX50 with DIA on (480x320) and Pleco with character recognition on the right of the screen. There's a new icon that collapses |->| / expands |<-| the bar on the right: when the the bar is collapsed, word definition text is cut off as if a box had been drawn over it after displaying the text. Text becomes visible again if I select it with the stylus.
This does not happen with DIA off (320x320). Not sure I made myself clear :?:
 

Attachments

#87
Not even sure if this is a glitch

Mike -

Really minor issue - I'm really just asking to see if this was on purpose or if it's a glitch. When in a flashcard session, when I reveal the answer, my handwriting in the sketch box disappears. While this is no big deal, I did find it sometimes helpful to refer back to my sketch to see if each each individual stroke was correct, especially with complicated charaters... The previous versions did not have this 'problem', but I wanted to find out if it was purposeful or if it was indeed a bug.

Seriously great work! P.S I love the ability to be able to reveal fields separately!! :lol:

K.
 
A

Anonymous

Guest
#88
Very pleased with latest version, although it looks like I shall have to settle on it without a timed auto-display flashcards option - particularly useful when doing mundane tasks at a table! (like recording model Gaokao examination materials).
A couple of problems I should point out occuring in the DA window. The tilde (~) is frequently missing in the Chinese examples of usage - whereas they are present in the full screen mode (for the same entries).
Also when using lookup in Plucker (set to show text in OS Search tool) and then highlighting and pulling up the DA, the buttons get rather scrambled. However, the applications remain stable and funtional if you can guess where the buttons are. So this is not much of an issue for me but I thought I'd mention it. Otherwise, terrific!
 
#90
bugs

hello mike,

3 things:

- it is still not possible to work on longer headwords or longer pinyin in the card edit screen as it will just leave the screen. a flexible field there would be helpful.

- there is an empty field in the fullscreen HWR that one has to use when editing custom entries. what is it for? it would be really nice if one could enter several chars at a time. (on my NX80, i often automatically start writing on the HWR at the bottom when i am in the card edit screen, as it is still visible. doesn't work, of course, but would be such a cool thing...)

- using hardware buttons to advance to the next flashcard (no matter if 'go to next' flashcard or 'correct/wrong' button) will show the next entry completely revealed. especially during a test session this is kind of a spoiler.


other than that, i didn't find any unmentioned bugs. you're almost there!


keep it going,





jo.


PS: how about a new thread for beta 2 feedback?
 

mikelove

皇帝
Staff member
#91
Guest - that's actually very useful to know; there are only a limited number of things that happen when you turn Input Field Compatibility on, so if one of them caused the chunk over-lock then that helps to narrow our search.

goulniky - I'm seeing this too on our UX50, we thought we'd fixed this but it looks like it it reappeared when we fixed a similar problem on palmOne devices. So this time we'll make sure we test the fix on both companies' models.

kkuguru - actually the sketch box should only be cleared when you advance to the next card, so this is definitely a bug - thanks for pointing it out.

Paul - timed auto-display is still on our feature list for 1.1, which is starting to look like it'll consist mostly of minor wish-we-could-add-but-we-ran-out-of-time tweaks like this. The tilde bug is a simple oversight on our part - we switched the data files to using double-width, Chinese-style tilde's but forgot to add code to Instant Access to convert them back into regular ones. The button scramble is very odd, I can't even think of what might cause that...

jo - a flexible field would be helpful in version 1.1, certainly :D I'm not sure what you're referring to with the empty field - we did have a feature like that in the works for a while (yet another 1.1 possibility) but we took it out of the interface months ago. The hardware button thing is just carelessness, the review-related buttons should be disabled when you're in test mode (and vice versa).

Thanks for the feedback, everyone!
 
#92
5-way navigator in radical input dialog

This is only a minor thing in the current beta2, but maybe it could be supported in the final version:

in the radical input dialog it is not possible to scroll the contents of the list box using the 5-way navigator (Tungsten|T, ...). Scrolling is only possible by tapping on the scrollbar.

Unrelated: I noticed that the problem of beta1 with umlauts getting destroyed when editing flashcards has gone. Thank you very much!
 
#93
display and pinyin parsing bug

hi Mike,

good job on the betas. I'm afraid i've found a bug of sorts...

look up tu3na4. first, the u has the umlaut over in, in addition to the 3rd tone mark. a bold-font display problem?

second, it says "see tu3gu4na4xin1". so i select it and hit copy-to-input-field. Now it's turned to tu3gun4, with the n in the wrong place, and i have to go switch it with the 4. Plus the third-tone u is still displaying with the dots.

-Dominic
 

mikelove

皇帝
Staff member
#94
haraldalbrecht - good point, we were originally planning to add a full-fledged selection cursor (so that you could scroll around with the 5-way navigator and not use the cursor at all) until we ran out of time, but we should at least add basic hardware scrolling support. I'm glad to hear the umlaut problem is resolved.

dom - the tone number miscalculation has been a long-standing problem for us, actually. It's very difficult to translate Pinyin text with tone marks into Pinyin text with tone numbers, because of ambiguities like this - the old Oxford E&C software (even in its latest version) contains a number of entries with similar translation problems. We came up with a pretty reliable algorithm for this which we now use in our dictionary editing work, but it's kind of processor-intensive and we're not sure how well it would work on Palm - we may not be able to fix this until version 1.1.

As for the mis-displayed tu3, this is indeed a bug in our bold font file (you're using a low-resolution Palm, correct?) - it should be easy to fix in the next update.

Thanks for the feedback.
 
#95
reviewing flashcards using a flag

Has anyone got the flags to work with flashcards? I am trying to mark certain cards that I want to review more often with a flag. Then in the Cards Session of setting up a New Session, I will choose the Mode of All Cards, and check the box for Required flags, and select the flag (the only flag I have created). But when I start the session, I get the No Cards found dialog, and I know that I have cards with the designated flag.

Bug or am I missing something?

Thanks,

Lonnie
 

mikelove

皇帝
Staff member
#96
Bug, sadly... we've made a lot of progress on bug-fixing in the last few days, though (finally got rid of the main source of T5-related crashes, after an almost Melvillian hunt for it) so this should certainly be fixed in Beta 3.
 
#97
Will beta3 require installing the complete set of files, including dictionary files again? It seems we had to do it for beta1 and 2 and it's a bit of a drag on the UX50 where I subsequently need to move ABC/NWP files to 'internal card' but large fonts on 'external card'
 

mikelove

皇帝
Staff member
#98
Nope, Beta 3 uses the same data files as Beta 2, and we expect 1.0 to use the same data files as Beta 3. The only data file we've changed is the large low-resolution font (to fix a bug where umlauts were appearing on non-umaluted u's) but of course you won't need that one on your high-res UX50.
 

Attachments

A

Anonymous

Guest
#99
(finally got rid of the main source of T5-related crashes, after an almost Melvillian hunt for it)
I have seen crashes with Plecodict on this new release, for the first time. Glad to hear this is sorted (and apologies for buying a T5, won?t happen again)

Roddy
 

Attachments

A

Anonymous

Guest
Re: more detail..

shindong said:
thanx for reply..
I've checked T5's latest update in the link that you attached.
firstly I'm using chinese version. (I bought T5 in china)
and.. version seems latest.

I also think pleco dict doesn't affect on Palm's hand writing recognition system, but pynin search and display was slow anyhow.

I'll give you some more detail.
hand writing stroke problem actually seems..
pynin search speed don't follows hand writing recognition.
when I finished first character's stroke, there are character that I wrote in input field.
But, if I write next character with same speed that I usually write on memopad.. on screen there are no stroke trail line and no response.
right after the fisrt character's stkoke recognition finished, I can see displaying delay.
it refreshs from top to bottom.. and it takes about 0.5s at least.
if you say 0.5s is short time and I can wait.. nothing to say.. but when data file was in 'internal'.. it wasn't like this slow.

anyway..
now I deleted some not desperately needed mp3 files and made more free space on 'INTERNAL' and did soft reset.
(before time there was 9.9MB free memory on 'INTERNAL' and now have 23MB)
I seems better.
I'm still not sure about the gettin' slower problem completely solved..
if there are any significant, I will report! ^^

加油!
 
Top