The PlecoDict Beta Feedback Thread

mikelove

皇帝
Staff member
#1
It's out now, so feel free to post your bug reports, comments, spirited discussions of toolbar icon aesthetics, etc here.
 
A

Anonymous

Guest
#2
Looking good 8)

I'll be spending some time playing with it and then see if I can come up with anything useful. My current issue is that I can't get Instant Access working on my T5 - I've mentioned this previously, but hadn't worried about it too much till the Beta. It WAS working previously, until I installed the T5 software update from palm, but now nothing. (I'm not sure if that's what caused the problem, but I think they happened around the same time)

If anyone out there with a T5 can tell me if they can get IA working, I'd be interested to know.

Roddy
 
A

Anonymous

Guest
#3
toolbar icons

mike,

can you make the toolbar icons smaller to spare room for more icons?
 
A

Anonymous

Guest
#4
Great! Very impressed with the many enhancements!

Yes, tool bar icons could definately afford to be smaller to allow more in.

Radical selection panel could do with small font option - I found the previous version pleasing and conducive to searching.

Again, with hand writing recognition, I prefer a greater offering of characters. I'm not sure that the recogniser is sufficiently error tolerant for many target users (me specifically).

Instant access works but leaves a space on the command bar instead of an icon.

The add to flashcard button (main and instant access) could do with some sort of quick visual confirmation of input (if sound is off).
Icons much more pleasing but perhaps the flashcard set could be a little softer/rounded.

The flashcard menu options look good...

Good luck with the next phase!
 
A

Anonymous

Guest
#5
Instant access works but leaves a space on the command bar instead of an icon.
I don't %^&%$^$& believe it!!!! The damned thing has been there for months, just invisible. One tap at the end of the command bar and up pops the instant access box. How did you figure out it was there?

Roddy
 
A

Anonymous

Guest
#6
Why have 2 icons to switch between E-C and C-E dictionaries? How about just an icon which activates a drop-down menu listing available dictionaries.

Selection list could be:

OXP C-E
OXP E-C
ABC C-E
NWP E-C

The icon graphic would display, for example, "NWP EC" (or whatever) to denote current dictionary selection.
 
A

Anonymous

Guest
#7
The new version is awesome, good work Pleco-team :D I'm Probably going to need some time to figure out all the new functions.

I got my wish for a chinese "theme", really cool 8)

Also, I used the automatic install on my T5 and it seems to work fine. (it didn't work before)

M
 
A

Anonymous

Guest
#8
Just installed the new beta version. Looks great!

I'm currently using a Tungsten C.

Now ever since I installed the latest version of PlecoDict, I'm running into the following bug from the main menu (where I select the application I want to start):

If I select the App menu and then choose any of the options there (Delete, Beam, Send, Info....), I get a Fatal Alert - "MemoryMgr.c, Line:3690, Invalid handle", and am forced to reset the device.

Anyone know how I can restore my device to the way it was before I installed this latest version of PlecoDict? I can't seem to access the Delete selection without getting this fatal error. I think I'd like to reinstall the older beta version unless there's a workaround.

Thanks for your help.
 

mikelove

皇帝
Staff member
#9
chiusa - just go to the Toolbar Preferences panel and lower the spacing from 2 pixels to 0 - that will make room for an extra icon. The current size icons are about as small as they can be while still being useful on small-screened devices like the Treo 600 and Sony Clie UX50 - I suppose we could offer more than one icon size, but I'm not sure if it's worth the effort for what would be at most one more toolbar button worth of space.

micas - we use the separate icons mainly because they're two functions which people might want to access independently - it's more convenient to be able to switch languages or cycle through dictionaries with a single button tap. We might be able to add an extra toolbar command for a button that would do both, but as above I'm not sure if it would be worth the extra effort for one more toolbar button slot.

rt - sorry to hear you're having problems. Have you tried disabling PlecoDict's instant access feature (if you had previously enabled it)? If that doesn't fix this, you could try a soft reset of your Tungsten while holding down the up directional button - that will start it up without loading any system extensions. If that still doesn't fix your problem, try downloading and installing the utility Filez (http://www.nosleep.net) - you can use that to manually remove each individual PlecoDict data file. (or just delete the PlecoDict Flashcards and PlecoDict User DB files, soft-reset your Palm and see if that fixes the problem)

And can you give me some idea about what configuration you installed PlecoDict in? Which data files, and where (SD card or RAM)? Did you try out the flashcard and/or custom dictionary features at all? Did you enable Instant Access?
 
#10
Looks great but I have to get used to the new interface.
Ok, I needed to take a quick look at the manual :wink: but it's all clear now. It's really good, there's so much more flexibility shriking/expanding, moving back and forth. Excellent work.
2 things :
  • One issue is the need to manually re-enter the registration codes (3 times in my case, PlecoDict, ABC, NWP). I followed the instructions and deleted the previous version, was there no way to keep those codes?
    Could one toolbar slot option be 'none' ? Not a big deal but on my UX50 in full mode I may not use all the options (12 slots)
 

mikelove

皇帝
Staff member
#11
Thanks!

There wasn't any way to keep your old registration codes - we thought we'd have our new keyfile system ready by now, but we're in the process of updating our online store software (along with moving the store to a faster web host) and we didn't want to go to the trouble of installing/testing it with our old store when the new one will be ready soon.

A "none" button option is a good idea, I think someone (maybe even you) mentioned it before - I'll add it to the list of finished-version tweaks.
 
#12
help option

hello,

this doesn't really belong here, but i already wrote two emails today, so:

for the future 'help' screen i would suggest to include a chart with all the abbreviations used within the dictionaries.

and btw: where is the custom dictionary stored in?


keep it up!



jo.
 

mikelove

皇帝
Staff member
#13
Actually our original design had a full-fledged glossary/appendix system (which we had to drop due to time constraints), but definitely this is something we'd want to include in the online help.

And the custom dictionary is stored in the file "PlecoDict User DB".

I'll reply to your (very helpful, thanks!) e-mails later.
 
#14
Really impressed! lots of good new things!

some questions-

Is it still possible to use the CEDict and UniChin dictionaries?

I found the 'delete non-matching characters' option on the old Oxford Dict really useful, can it be put back in? (actually on my T|W this option did a funny thing- it wouldn't actually delete the non-matching characters, but would simply ignore them . . . could this be another option?)

One strange bug: when an entry has a very long definition (longer then the available space) and I use the hardware up-down buttons to move through the definition, after about a second it will bounce back to the original position by itself! The same thing happens if I am moving through the entry-list, it will bounce back to the original word. There is no problem if I use the pen to move through the entry-list/ definition.

Still very pleased, looking forward to the final version.

Henry
 
#15
penpower

With the 'input field compatibility mode' selected and external text encoding set to GB penpower is working great!

A question tho- in the input field it looks like it is using a low-definition font file, but in CJKOS I have the high-definition fonts installed, do you know why plecodict is choosing the low-def. fonts?

Everywhere else the pleco high-def. fonts are being used.

Thanks, Henry
 
#16
I'm very pleased with the new version. I especially like the chinese character toolbar icons and the fact that I can now enter a pinyin syllable and get all the matching characters without any compounds!

I like the new search screen as well, but it caused a fatal exception very quickly (With "Open fullscreen list" on and "Close fullscreen list on tap") I get a fatal exception whenever I delete characters from the input list.

Also, the enable search button doesn't seem to work. Even with it enabled it still searches automatically (which can be annoying on OS 4 devices despite the vastly improved speed over the preview versions).

Also, I cannot seem to import flashcard lists correctly. I've made a list of words I want to study, all separated by a newline. Whenever I try to import I only get one empty flashcard.

In the ordering dialog, there's a "User C-E" in the Paid dicts list. I assume this means that your going to release a tool for importing your own user dictionary. I hope this will give me an option to import my Chinese-Chinese dictionary, since this is the thing I miss the most about Plecodict right now.
 
#17
Flashcard session is not working correctly

So you warned us that this version was going to be buggy, so I guess I shouldn't be too surprised. I am impressed with the flexibility of the flashcard system, but whenever I try and run a new session showing only the PY, there is nothing on the screen. When I first imported my flashcards from Oxford, there was no problem and I could test showing PY or Characters or whatever. After playing with the settings, I can no longer test showing PY or Definitions, but testing showing characters still works. Even though I changed everything back and even tried reinstalling the whole thing, it still just shows a blank screen when I have the settings for PY. It seems to work correctly appart from this rather major bug, since I can't run a flashcard session the way I need to be tested to start getting my cards in the correct ranking.

I am using a Treo 600 with the ABC installed to the expansion card and everything else installed in the main memory.
 
A

Anonymous

Guest
#18
I see error message quite a lot.

I'm using T5.

from version 0.87 untill now beta1 version, I see almost same error message and soft reset button.

"PlecoDB.cpp, Line:1146, Can't switch working record"
(the line number part changes everytime.)

I'm studying chinese almost all day long.. so I use PlecoDict alot.

It seems mainly when I changes searching method.
for example.. search several words with handwritng recognition then search with pynin, error occur.
opposite way also sometimes occur.

if I search chinese words continuously 10min. almost everytime it happen.
(sometimes just in the middle of downscroll words list on right-side)

It is kind of random. and it's really annoying!!!
(you know T5's reset takes pretty long time)
I do reset my T5 at least 15 times per day by just using PlecoDict with everytime same reason, same message.

hope hear from you some good news soon~
and just one thing I wanna add... I really like PlecoDict!!! ^^
 
#19
Looks great Mike and Co. Maybe it's time I plunk down for ABC and NWP.

One problem. As best I can determine Back and Forward (from the Dict menu) don't take me (as I'd like) backwards and forwards through the Most Recently Viewed Entry List (the drop-down from the Input Field) but rather moves me (starting at some position whose origin I can't determine) between single-character (not compound) entries in the Entry List (on the right).

pat
 

mikelove

皇帝
Staff member
#20
Henry - you can't use CEDict and UniChin with this release, but we plan to include those databases with the final version. Actually we've found an expanded version of CEDICT (120,000 entries or so), and since we now support Unicode we can use the full 20,000-entry UniHan database instead of the 7,000-entry GB subset in UniChin, so these databases should be greatly improved over their older versions.

The delete non-matching feature was disabled on the T|W (and in fact on all devices with Graffiti 2) because it could cause problems when entering certain letters - not actually a problem on the T|W, because it had a keyboard as well as on-screen handwriting input, but for example on a Tungsten E you enter the letter 'i' by entering an l followed by a dot, and as soon as that 'l' appeared the dictionary would try to search for it, not find any results, and cut off the 'l' before you had the chance to turn it into an 'i'. I suppose now that we have this search delay feature we could add it back in, I'm not sure if we'll have time to do it for 1.0 but it might be an option for future releases.

And do you currently have the search delay feature turned on? That seems like the most likely culprit for this springing-back bug, it's about the only part of the software where something happens after a 1-second delay.

As for the low-definition fonts, are you sure that you've installed CJKOS' high-res fonts both for simplified and traditional characters? This might actually be a CJKOS bug (or even just a Palm OS one), the Tungsten W contained a very early version of Palm's high-resolution screen feature and there might be some sort of incompatibility there that was corrected on future Palms. Unfortunately, there's no Tungsten W emulator available so it's very difficult for us to do much testing on this...

curwenx - thanks for the crash report, we'll investigate this and fix it for 1.0. The enable search button is actually doing what it's designed to, but we should probably add a "button only" option for search delay - the current system is a bit silly. And with flashcard import, did you create the wordlist on your PC or on your Palm? And are you sure you configured the text encodings correctly?

The User C-E option actually shouldn't be showing up in there (that's the name of the custom dictionary database), but yes, we are planning to release a tool for creating your own dictionaries on the desktop instead of just on the Palm. Right now we're just focusing on getting PlecoDict 1.0 out the door, but once we finish that we'll get to work on the converter utility and it should hopefully be ready a few weeks later.

kkuguru - try disabling the "Magnify characters in headword" option in Test Settings, that should get around this bug. (of course we're going to fix it too, but this should get it working in the meantime)

shindong - try moving the PlecoDict databases from your T5's internal memory to the flash drive. You can do this with the free utility Filez (http://www.nosleep.net) - copy the fonts and dictionaries from "Internal" to "INTERNAL" and make sure you put them in the /Applications directory or in /Palm/Launcher or /Palm/Programs/PlecoDict. This won't make any significant difference in speed (the files are stored in flash memory either way), but it should help with your crashing problem.

This is a problem specific to the T5 and the Treo 650, one which we're hoping to find a solution to it before we release the finished version (otherwise we'll put up some sort of warning message when you first run PlecoDict); it's not likely to affect Treo 650 users much, since they don't really have any choice about whether or not to put PlecoDict on an SD card, but with the T5 it can be very annoying if you put the files in the wrong place.
 
Top