Google ARC Welder

Discussion in 'Future Products' started by etm001, Apr 3, 2015.

  1. goldyn chyld

    goldyn chyld 状元

    Wow, Ctrl-V really works on OS X, thanks for that! :)
     
  2. Miguel

    Miguel 状元

    Moro's comment is valid for both ARC Welder and ARChon
     
  3. So it's been a while now, what's the consensus on:

    ARC Welder vs. ARChon
     
  4. Miguel

    Miguel 状元

    I don't know if there is a consensus but after trying both for a while under Linux, in my case, I prefer ARChon. A little bit harder to configure but it is much more stable in my computer.
     
  5. That depends: in my Lenovo Flex-15+Windows 10 ARChon was initially the only one that worked, so I choosed ARChon. It's necessary make some test.
     
  6. Miguel

    Miguel 状元

    In my opinion, try both and see what works better in your computer :).
     
  7. Screen Shot 2016-09-16 at 10.15.16 PM.png

    Uhhh, what's this?

    edit; whatever it was - ARChon seems to have sorted itself out now
     
    Last edited: Sep 16, 2016
  8. Miguel

    Miguel 状元

    Hi,
    In the last few days something weird is happening in my dear Pleco-ARChon. Whenever I copy a text from Libreoffice 5 (also Openoffice 4), Pleco recognizes it with a few CSS labels before the Chinese text. For example, if I copy "你好" from a document in Libreoffice, Pleco (instead of opening in the dictionary like 你好) will open it in the Clip Reader like :
    @page { margin: 2cm } p { margin-bottom: 0.25cm; line-height: 120% } a:link { so-language: zxx }
    你好

    I use Linux Mint 17.3 (Ubuntu 14.04), Chrome 54.0.2840.59 (64-bit), Archon 2.1.0 - 41.4410. I've tried installing last version of Pleco but it happens the same. If I copy from any other source Pleco will open it correctly (Text editors, webpages, pdf...). The problem is that I have no idea where the problem is coming from (Chrome-Libreoffice, ARChon...). I know that this is not really related with Pleco but if anyone could point me in some direction to try to solve this... I use everyday for studying the combination Libreoffice-Pleco :(
     
  9. mikelove

    mikelove 皇帝 Staff Member

    Sounds like formatted text that's not being tagged as formatted text; ARChon is forwarding that text along to Android as if it was plain text and Pleco duly accepts it as that rather than recognizing it as formatted text and converting it to plain.

    The workaround would be to force the clipboard to convert to plaintext before (or while) pasting it into Pleco. I believe on Ubuntu you can use control-shift-V to paste the clipboard as plaintext; there may also be some system extensions available that will make that conversion for you automatically.
     
    Miguel likes this.
  10. Miguel

    Miguel 状元

    Thanks, Mike. Right now that's what I am doing. Either pasting in the text editor before pasting to Pleco or getting the pasted text from my Clipboard monitor app (Clipit). I think it all messed up with the last update of Chrome a few days ago, and nothing else has changed that I can recall. Funny thing is that sometimes it works fine :confused:.
    I hope this gets solved in future Chrome updates
     
  11. Miguel

    Miguel 状元

    Definitely is the last version of Chrome. To solve it I've installed Slimjet 12.0.4.0 (browser based on Chromium 53) and everything seems to be working fine again. Since Chrome updates so much and ARChon seems not to be developing anymore, I've disabled the updates in Slimjet and made copies of all these files just in case (Pleco is one of the apps that I use most and I do it much more in my PC than in my cellphone). I guess it should work also with Chromium 53, but in my case Pleco won't start. For my ARChon-Slimjet configuration Pleco 3.2.29 works better than 3.2.35 (for example, in the last version I can't copy text from the app).

    EDIT: One day later Chrome has updated again and now Pleco is crashing so I would suggest finding an older version of Chrome (or derivative) and keep a separate copy of it from the Chrome browser one and use the older one only for ARChon-Pleco
     
    Last edited: Nov 8, 2016
  12. KingMarcus

    KingMarcus Member

    I tried this method today but getting errors in Pleco and Archon. Any ideas? Anyone else having problems with the Archon, Pleco setup? Thanks.

     

    Attached Files:

  13. Miguel

    Miguel 状元

    Which version of Chrome and ARchon are you using? Which OS?
    In my case, on Linux and using Chromium I couldn't make it work and I was getting similar errors like yours.
     
  14. KingMarcus

    KingMarcus Member

    I'm using Version 54.0.2840.87 m (64-bit), and I also tried in Canary- Version 56.0.2912.0 canary (64-bit). For Archon I have ARChon 2.1.0 Beta (ARC 41.4410.238.0)x86, 64 bit. Is there any work around? Maybe using an older version? Detailed instructions on this anywhere?
     
  15. Miguel

    Miguel 状元

    Try an older version of Pleco. In my case 3.2.29 is working fine (there are newer versions that don't work that well). Also you could try an older version of the Browser since ARChon is not updating anymore. A few posts before you can check my configuration with an alternative browser based on Chrome called Slimjet. I was getting similar errors under Chromium (I've never been able to make ARChon work with it)
     
    Last edited: Dec 3, 2016
  16. Azimuth

    Azimuth 秀才

    Also not able to get ARchon+Pleco working - on macOS 10.12.3.

    I get the errors: (ARChon Custom Runtime 1.2 - x86_64)
    • 'minimum_chrome_version' is only allowed for extensions, legacy packaged apps, hosted apps, and packaged apps, but this is a shared module.
    • Unrecognized manifest key 'arc_build_tag'.
    (Pleco 3.2.23)
    • Unrecognized manifest key 'arc_metadata'.
    Any suggestions? I can't use Slimjet because it's windows-only.
     
  17. Have you followed these instructions? (Don't forget to download the attachment as well.)

    I'm running this on 10.12.3 without any issues.
     
  18. Azimuth

    Azimuth 秀才

    Yes, those were the instructions I followed to get this far.
     
  19. Screen Shot 2017-06-09 at 4.34.21 PM.png

    anyway to fix this with ARChon?
     
  20. In effect only new Liang and Hui Voices are compatible with archon.

    Hong, Qiang and Yafang voices are not compatible: an emulator is necessary.

    I'm testing http://www.memuplay.com/ emulator (Vers. 3.0.4) but I haven't verified the compatibility with last three voices.
     

Share This Page