Google ARC Welder

Discussion in 'Future Products' started by etm001, Apr 3, 2015.

  1. jejohnston

    jejohnston Member

    I tried installing the latest beta in ARC Welder, but have actually found it less functional for flashcards than the previous version.

    I saved a back-up of flashcards from my phone and copied it to the virtual Android folder on my desktop, but when I tried to restore this to Pleco running on ARC Welder I got a failure message. I thought it might be a compatibility problem because my phone is running the release version of Pleco not the beta, so I tried importing the New HSK flashcard list from the Pleco website to see if that would work, but that also failed.

    Have other people managed to get flashcards synched using the new beta version? Previously, I was able to get my flashcards onto ARC Welder, I just couldn't back-up any changes made.
  2. @jejohnston As for me I've never used the restore function, just copied the flashcard backup file renamed Pleco Flashcard Database.pqb to <PlecoStorageRoot>\Android\data\com.pleco.chinesesystem\files\databases. Make sure you do it when Pleco is not running, and also delete the .pqb-shm and .pqb-wal files if they are present. I haven't really been using flashcards with ARC Welder so far but they appear fine this way, so hopefully this works for you too.
  3. jejohnston

    jejohnston Member

    Thanks Captain Planet, I've got it working now.
    Captain Planet likes this.
  4. Wan

    Wan 榜眼

    Is it possible in Arc Welder to update a previously installed version of pleco with the latest apk file, and to keep the registration and installed files? Maybe by copying a folder?
    edit: Or, to rephrase the question: Can I simply copy & paste the com.pleco.chinesesystem folder?
    Last edited: Jul 21, 2015
  5. Is anyone still able to use ARC Welder with the current Chrome builds? With one of the updates to Chrome it just stopped working for me, Pleco just would not launch anymore (it start and appears to be running in the background but no window ever shows up). I didn't even notice it straight ahead as I used it sporadically this way but it's nice to be able to use it on desktop sometimes. (I tried all the usual tricks of removing everything and installing afresh, etc.)

    If it works for you could you please state your Chrome version and platform, whether they are 32-bit or 64-bit, and Pleco APK version (or filename).

    The following doesn't work for me at the moment:

    Chrome 47.0.2526.106 m (64-bit), Windows 8.1U1 x64
    Pleco APKs: plecodroid-150402p.apk and plecodroid-151112-website.apk

    As the ARC welder does not produce any error messages or logs and the output from adb logcat is also empty, it's difficult to see exactly what is going on. If it works for someone else, it would mean it can be made to work on my computer too, so I'll give it some more attention but from searching for ARC Welder topics it appears that many things about it appear to be broken (not just with Pleco), so perhaps it can't be made to work anymore at all?

    Comments appreciated.
  6. Last edited: Jan 10, 2016
    sobriaebritas, Wan and Captain Planet like this.
  7. Excellent! Archon is exactly what I was looking for, hoping someone out there had done something like that. Thanks a lot!

    A quick summary for anyone else who wants to use it as well:

    Running Pleco in Chrome on a PC
    1. Download Archon (vladikoff-archon-*.zip) and extract it somewhere.
    2. Download from the attachment below and extract it somewhere else.
    3. Download Pleco Android APK. The last version that works well with Chrome appears to be: plecodroid-150402p.apk.
    4. Rename the APK file to Pleco.apk and put it in PlecoChrome\vendor\chromium\crx.
      (Sorry about steps 3 and 4, I couldn't include the APK in as it would exceed the attachment size limit.)
    5. In Chrome, open chrome://extensions. Check Developer mode in the upper right corner.
    6. Click Load unpacked extension... and choose the directory where you extracted Archon.
    7. Click Load unpacked extension... again and this time choose the directory where you extracted PlecoChrome.
    8. Click Launch under Pleco.
    • During the first launch you will be asked to select a location for Pleco storage. You can choose a directory with existing Pleco files to avoid downloading them again.
    • When Pleco is running, you can create a shortcut to it by right-clicking on the taskbar and choosing Pin to taskbar. The shortcut can then be moved anywhere you want.
    • When reopening, Chrome will ask you to disable developer extensions. Don't do this, or Pleco will stop working and will need to be re-enabled on the extensions page.
    Thanks again @Furio Petrossi for sharing this excellent idea.

    Attached Files:

    Miguel, sobriaebritas and Wan like this.
  8. Wan

    Wan 榜眼

    Thanks for that. I had been using an older version of ARCwelder (on Linux) and an older version of Pleco, and it worked quite well. I never updated either because I feared it might stop working. All the features worked as well, but your way, using Archon, has less glitches and seems to be a bit faster.
    Captain Planet likes this.
  9. Moro

    Moro 秀才

    I've successfully installed it on Linux on recent versions of everything (Chrome, Arc Welder, Pleco). Chrome says it's "Version 48.0.2564.97 unknown (64-bit)", running on Ubuntu 15.10. For comparison I've tried the Archon method that also worked, but it seemed that it ran slightly slower. Couldn't use clipboard monitoring in either of environments. It's a rather old computer, so instead of running sluggishly it hang using 100% of the CPU and I had to reinstall it.

    Also I wanted to try the OCR on a file, it said that it couldn't establish a connection to the camera (fair enough, there isn't one) and that I should go to "Settings/OCR" and enable "Default to Still Image". But there does not seem to be a setting like this in this version.
    Captain Planet likes this.
  10. mikelove

    mikelove 皇帝 Staff Member

    @Moro - try invoking OCR via the sidebar menu / Still OCR instead.
  11. Moro

    Moro 秀才

    Yes, that's what I did (I'm not aware of another way, actually)
  12. mikelove

    mikelove 皇帝 Staff Member

    That's odd, then - which command were you choosing under Still OCR? (several different places it'll offer to open a file from) Did this error come up after you picked a file? It might be that the file was inaccessible.
  13. Moro

    Moro 秀才

    I'm choosing menu/Still OCR/Open Image File and then I open a PDF file. I've tried several and they all give an error. JPEGs seem to work. Just to be sure it's not a problem with the files themselves I've tried the same PDF file on Android and it works fine. Not a big deal, I can read files on a tablet.

    While we are on the subject, is there some way to quickly move around in PDF files? There is the ">" button, but I didn't find a way to jump, say, to page 150 of a file.
  14. mikelove

    mikelove 皇帝 Staff Member

    Ah, PDF could be the issue then, definitely - memory or something else.

    Try long pressing the > button to jump to a specific page.
  15. Moro

    Moro 秀才

    Does not seem to work for me on Android (4.4.4, actual tablet, not under Chrome). It just pops up a little balloon with one word "Image" that goes away in a few seconds.
  16. mikelove

    mikelove 皇帝 Staff Member

    Sorry, forgot that was only on iOS - should be on Android in our next update though :)
    Moro likes this.
  17. Moro

    Moro 秀才

    Great, thanks!
  18. Robert Wilder

    Robert Wilder Member

    This is truly a godsend! I would love to be able to have Pleco available for desktop for as long as possible...
  19. Wan

    Wan 榜眼

    I used this method to install Pleco, and it worked. I could also enter my ID and download my addons. But after the Jan 27 releases, it wouldn’t show any of my new purchases (not even after clicking “Check for other purchases” or after deactivating and reentering my ID) in Pleco. It wouldn’t even show the new dictionaries in the addons screen.
    After deleting from my chrome folder all files related to archon, I reinstalled everything. I used the latest archon build (latest Beta from, and the latest version of pleco ( I haven’t tried all of Pleco’s features, but everything related to dictionaries should work. Choosing “Remove Icon” when clicking the camera button doesn’t do anything, but apart from that, it seems fine. Haven’t tested the reader or flashcards function.
  20. Gene

    Gene Member

    Much respect to MikeLove and this forum. Bought a reclining, touch screen desk top with the specific intent of reading and editing Chinese docs by hand on it. Will let you know how it goes. 加油魚!

Share This Page