Manual flashcard backup to Google Drive blank

I just backed up my flashcards to Google Drive manually (i.e. instead of when prompted that it had been more than a week), and the file is blank. I saved to a local file and the file is as expected.

Backups done when prompted (pictured with dates before today) seem to generate two files - one blank, one with data.



Staff member
Hmm, that's an odd one. What brand / model of Android device do you have and what version of Android is it running? Is your copy of Google Drive up-to-date? Can you try backing up to another cloud storage service and see if you get similar behavior there? If you try to actually download one of these blank files is it in fact blank?
It's a Vivo X6 running Android 5.1. I don't have any other cloud uploads to test on (I have dropbox but the only save options are Google Drive and Local).

The files are definitely blank. They're 0KB, I opened the xml and no text in there, and Pleco doesn't recognise them when restoring.


Staff member
OK, we'll see if we can reproduce this, but to be honest, on a device that old with that early a version of Android's file storage connector system, it may turn out to be an issue in Google Drive that we can't easily work around.
That happened to me about 2 days ago too, on a Pixel 1 running Android Pie. I suspect a transient bug in Drive, perhaps a server-side one or a bad app update. I was also migrating to a new phone, and worked around that by attaching the backup to an email instead.

Seems to be fine now on my new phone, not sure if the issue persists on the old phone.
I've replicated the bug twice on my S8 running Android 8.0, standard Samsung variant. Backups saved locally are fine. Backups saved to GDrive from inside Pleco are 0 kb. Is it possible to save to other cloud services from inside Pleco, to maybe isolate a variable?
Exactly the same again for me, writing 0b files to Drive but local backups are ok. Tried 3 times in a row over the last hour, and it's always empty. Pixel 3 XL stock firmware.

Edit: one out of 10 of my save attempts worked just now.


Staff member
You can save to any cloud service that interacts with Android's storage manager, yes.

We haven't managed to reproduce this here, so my guess would indeed be a transient issue in Drive. (there isn't really a lot of Pleco code to debug here, we hand the system a link to the file and it does the rest - from our app's perspective there's zero difference between saving locally and saving to Drive, we don't even know where the file was saved)