Difficulty remapping flashcards to custom dictionary

#1
Hi,

I'd like to remap some flashcards to custom dictionary entries in a particular flashcard test (to see the pneumonic for the character during the learning process) without altering the overall dictionary that the flashcard is associated to since I use it in other tests (to review the character).

I tried to do it within the test by going to Display > Definition > Remap cards to dicts > Yes > Dicts > Excluding all dictionaries except the custom dictionary containing my pneumonics.

However it doesn't seem to be working, in the test the flashcard still shows its original associated definition and not the definition in my custom pneumonic dictionary.

Could anyone show me what I'm doing wrong?

Many thanks,
Natalie
 
#2
Hi Natalie,

could it be that the Simplified Hanzi, Traditional Hanzi, as well as the pinyin aren't exactly the same in the mnemonic dictionary as in the dictionary associated with the flashcard? I believe all three have to match for Pleco to consider two dictionary entries to be for the same word.

If I’m right, it might be possible to change the mnemonic dictionary in some automated fashion with Excel by exporting both the mnemonic and the other dictionary and matching the entries up.

Cheers,

Shun
 
Last edited:

mikelove

皇帝
Staff member
#3
That most likely explains it, yes. There are commands in Batch to remove and to auto-generate portions of flashcards so that they’ll match up with whatever is filled in in the dictionary.
 
#4
Hi Shun and Mike,

Thanks for your suggestion. I'm not quite sure how to export the flashcard and mnemonic dictionary to check that.

However I don't see how those 3 fields could be different since I created the mnemonic dictionary entry by:
- adding a flashcard to a category straight from a standard CC dictionary entry
- clicking edit on a card
- typing in my own personal mnemonic in the definition field
- not altering the simplified character headword, traditional character headword or Mandarin pronunciation
- clicking the new entry button

So my custom mnemonic dictionary pulls all those 3 fields directly from the flashcard's main CC dictionary and should always be the same.

Also when I look up that word in the multi dictionary search, my mnemonic comes up at as one of the possible definitions and my mnemonic dictionary is listed as one of the possible dictionaries to have an entry for the word.

Could the remapping issue be caused by something else?

Thanks again for looking into this for me!
 
Last edited:

mikelove

皇帝
Staff member
#5
Could you email me (mikelove at pleco dot com) backups of your flashcard and user dictionary databases? Can't seem to reproduce this problem here.
 

mikelove

皇帝
Staff member
#7
OK, found the problem here - the test is set to use Cantonese as the main pronunciation, but user dictionaries don’t support Cantonese, so Pleco prioritizes the Cantonese part over the user dictionary part and consequently skips your user dictionary so that it can still give you something with a Cantonese reading.

At the moment the best workarounds I can offer are to:

1) Convert these back into flashcards (which do support Cantonese) instead of user dictionary entries, in which case everything should work fine. You can use the ‘remap’ command to have them come up in CC-CEDICT in all other tests.

2) Permanently remap the flashcards to point to your user dictionary and again remap them to CC-CEDICT for all other test types. (it won’t skip the user dictionary if it’s explicitly linked from the card)

2) Run the test in Mandarin instead of Cantonese.
 
#8
Awesome! Thanks so much Mike! I would have never guessed it was a Cantonese issue.

How do I go about converting these back into flashcards (option 1)? I thought they already were flashcards. I had a dig in the manual and menu but can't quite figure out what you mean and what to do.

Many thanks,
Natalie
 
#9
Hi, that’s an easy one, here I can help. :)

You can go into Settings / Manage Dictionaries, open the user dictionary with the mnemonics, tap Export Entries, save to a UTF-8 text file. Then, you edit the exported file. You add "// {path to where you want the mnemonic flashcards to be}" as the first line of the file. Then, you go into Import / Export > Import Cards, choose Import, select the edited text file, make sure "Store in user dict" is disabled, set Duplicate entries to Allow. Then tap Begin Import, and your flashcards will be added.

What's different now is that you do not remap the cards when you want the mnemonics, and you remap to CC-CEDICT when you want the regular English translation.

Cheers, Shun
 
#10
Thanks so much for your help Shun!

Is there an easier in-app way of coverting the entries into flashcards?

The reason I ask is because exporting then importing is going to be a bit impractical for my use case. I create 3 new user entries everyday as I slowly work through the list to create my own mnemonic for each character. I often do it on my phone on the go. Then I add the 3 flashcards to my test category because the Heisig Learn Traditional Hanzi system I'm using relies on cumulatively learning the characters in a specific order, not randomly from the pool. So it would be a bit annoying to have to export, sync up to computer, edit the file and re-import everyday for only 3 cards.
 
#11
You’re welcome!

As I see it, you would have to convert the entire user dictionary to flashcards only once. After that, you could add new mnemonic flashcards right in Flashcards. So you could go into Organize Flashcards, go to the mnemonic category and tap New Flashcard there. To avoid having to input the Hanzi and pinyin, you could also add the word you want to add the mnemonic for from the Dictionary using the "+" button, then go into Organize Flashcards, Convert to custom card and replace the card’s definition with the mnemonic.

Hope this helps!
 

mikelove

皇帝
Staff member
#12
You could also import them with duplicate handling set to 'update text' - that way, the cards themselves won't be replaced but their definitions will be updated to your new mnemonic ones.
 
#13
Thanks so much for your help Shun and Mike!

I think I've got it to work now using Mike's 2nd option.

Shun I actually already create flashcards by clicking on the "+" button from the Dictionary (selecting CC-CEDICT). But since all my mnemonics are in my mnemonic user dictionary, now I just click the "+" button next to my mnemonic user dictionary entry instead. Just like you said, there is no extra typing required.

Then as Mike suggested, in all the other tests where I don't want my mnemonics to be displayed I've forced it to be mapped back to CC-CEDICT within the test profile.

It looks pretty ugly in my Organise Cards folders, but it displays correctly in my tests.

Thanks again for your help guys! I never could have figured this out on my own!
 
Top