3.2.x Bug Report / Feedback Thread

caesartg

榜眼
Strangely if I input "123456", it shows "113456" under the selected color square. When I click on the square, it shows me my entered "123456" value.
 

mikelove

皇帝
Staff member
I do see it, yes, I'm just trying to see if I can come up with a workaround for you until we can fix it :)

But the color changing slightly when you exit / re-enter is normal, it has to convert between a couple of different color spaces - our future plan for this is to support + push people towards using iOS dynamic system colors instead of arbitrary ones, so you'd just pick 'red' and not have to fret about the precise shade of it.
 

koyno

Member
@mikelove ,

iOS 16.5, Pleco 3.2.70

When Search Interface > Embed definition toggle is on, Dictionary > Stroke section is empty.
 

Attachments

  • IMG_A20FB50649F2-1.jpeg
    IMG_A20FB50649F2-1.jpeg
    484 KB · Views: 44

mikelove

皇帝
Staff member
Hmm, not seeing this here - does it make any difference if you switch around the setting so the search result list is on the top instead of the bottom?
 

mikelove

皇帝
Staff member
No luck reproducing this even with the same settings: does it perhaps make any difference if you kill / reopen Pleco or if you toggle out of night mode?
 

laobaigou

举人
Quietly removed, but not by choice - Apple marked a couple of the relevant programming interfaces as private APIs (I guess not a lot of people trying to run web servers on phones anymore) and so we were forced to remove them.
is it possible to reload an older version with that feature? This is a real PITA!
 

mikelove

皇帝
Staff member
is it possible to reload an older version with that feature? This is a real PITA!

Unfortunately no, not possible to revert to older versions on iOS. My guess is that those APIs will go away entirely in iOS 17 or 18, so the feature probably wasn't going to be long for this world in any case.
 

Shun

状元
Hello Mike,

running Pleco 3.2.70 on iOS 16.4.1 (a), I noticed that I cannot share large PDF files from another app such as Dropbox or GoodReader to Pleco. Sharing other file types like DOCX to Pleco works—the file will automatically open up in Pleco as always. But when I share a PDF, I briefly get a progress indicator, after which Pleco won't open itself. Checking manually afterwards, the exported file can't be found in the /Inbox directory.

Thanks for having a look, regards,

Shun
 

Shun

状元
I now tried it unsuccessfully with a 30 KB PDF, so its size doesn't matter. If I open it through Reader > Open Document from iCloud, I can open the PDF, but I can't copy the file over to Pleco.

A different iPhone running the same versions of Pleco and iOS doesn't exhibit this problem at all with PDFs of any size.

Having learned that, I restarted the faulty iPhone and tried the export again, but without luck. I guess this is a tricky bug to fix. I could reset all my Pleco settings.
 
Last edited:

mikelove

皇帝
Staff member
Yeah, the 'share' menu in general seems to be a part of iOS that works only inconsistently and that Apple engineers are terrified of touching for fear of breaking something. It's unlikely to be anything to do with Pleco settings - much more likely it's something weird in the way the share file mappings are set up; if you wanted to try a dramatic step you could delete and reinstall Pleco and see if that improves matters.

Opening through External Files should make a copy of the file show up in "imported files" - does it?

(we should probably just show the Pleco documents folder in Files so that you can copy files into Pleco's storage area without actually having to rely on Share to work correctly)
 

Shun

状元
Interesting - indeed, the External Files I opened from Pleco can be found in the "/Imported Documents" folder. So that pretty much solves it for me, avoiding a full reinstall for now. Thanks!

It would be nice to be able to see Pleco's local files in the Files app. Even more convenient, if that wouldn't entail additional complexities, would probably be an additional iCloud Drive folder accessible from Pleco and anywhere else. Perhaps that's for the next major release.
 

mikelove

皇帝
Staff member
Local is a bit easier than iCloud Drive but we actually have some old code for an iCloud Drive folder that we never quite got around to polishing for release - anyway both are definite future possibilities.
 

Hailibu

Member
The color is reflected in the color picker. When I click "< Back", it reverts to whatever the color was before.
I found this same issue of when directly (and only) changing the value of the hex color manually, the new color doesn’t stick when exiting the interface. I found the workaround is to manually move the color picker before changing the hex value. Then the new color will stick. If you never move the color picker and just change the hex value manually, it won’t save the change.
 

Abun

榜眼
I’m not sure what might be causing this and if the cause is a bug per se or a mistake in the data files: The other day I found a word whose entry seemed to be mistakenly merged with an entirely different one (出現 and 閱讀) for unknown reasons and made a screenshot, but then forgot to report. But just now I ran into another (反映 and 地位). I attached screenshots for both.
 

Attachments

  • Screenshot_20230613-122058.png
    Screenshot_20230613-122058.png
    199.4 KB · Views: 37
  • Screenshot_20230626-172706.png
    Screenshot_20230626-172706.png
    192.2 KB · Views: 35

mikelove

皇帝
Staff member
Thanks - any chance that you might have a user dictionary entry for one of those words that also contains the other one in one of its headword fields? Which other dictionaries have you installed?
 

Abun

榜眼
Thanks - any chance that you might have a user dictionary entry for one of those words that also contains the other one in one of its headword fields? Which other dictionaries have you installed?
You’re right, that seems to be the source of the issue. The problem seems to be in certain German-language user dictionaries: HanDeDict has 閱讀[出现] and FLTRP has 地位[反映]. I guess that might make corrections a little more difficult for licensing reasons?
 
Hi, when in the live OCR, I use both tap to video to pause and to resume. Tap to pause works well, but tap to resume stopped working (I tried to deactivate/reactivate, force quit the app: no effect). Anyone noticed it as well?
Hi, I just realized that now “tap to pause video” also stopped working
 
Top