3.2.x Bug Report / Feedback Thread

Oh well... thanks for the explanation. Using share sheet achieves what I want, though not quite as convenient. I guess that "custom server port" file manager setting can get chopped too now ;)
 
Hi, in the document reader, in order to avoid seeing the pinyin over the characters in a pdf, I activated the “vertically scroll pdf” option. Everything worked perfectly until recently. Now, reaching about half the page make it jump to the next one, or go back to the top. The only change I’m thinking of is updating to iPadOS 16.2, and updating Pleco to 3.2.70. I tried to quit, restart the iPad, de/reactivate the scroll option, load another pdf: all without success. It doesn’t seem to have this behavior if I zoom in a lot (but then I can’t read obviously). Do you know what I could do to fix? Thanks.
 
Last edited:

mikelove

皇帝
Staff member
I'm guessing it's a 16.2 thing, since we didn't change any code relating to PDF reading in 3.2.70 (or update to a new SDK that might bring its own hidden behavior changes) - does it still work correctly if you turn off vertical scrolling?

Also, what do you mean about "seeing pinyin over the characters"? Is this a PDF that offers them as some kind of a hint and you're scrolling the page so as to keep the pinyin for the line of text you're reading concealed under the title bar?
 
I'm guessing it's a 16.2 thing, since we didn't change any code relating to PDF reading in 3.2.70 (or update to a new SDK that might bring its own hidden behavior changes) - does it still work correctly if you turn off vertical scrolling?

Also, what do you mean about "seeing pinyin over the characters"? Is this a PDF that offers them as some kind of a hint and you're scrolling the page so as to keep the pinyin for the line of text you're reading concealed under the title bar?
Hi,
My file is a typical workbook text, with the pinyin above the line of characters. Since I can’t turn it off, I like to scroll the pinyin line to the top to hide it.
If I turn off vertical scroll, then well, I can’t scroll so I can’t reproduce the bug. I tried to zoom in so to be able to scroll, but then it is as with scroll enabled: the text doesn’t jump (but the text is so much zoomed, especially reaching the bottom of the page, that I also need to scroll left/right, which is quite annoying).
 

mikelove

皇帝
Staff member
@Pierre Biannic - does it help matters any if you turn off the option to the show the thumbnail bar? (also in Settings / Reader)

There seems to be a weird bug in iOS 16 where having that turned on causes the PDF to constantly scroll back to take snapshots of itself in order to update its preview. (whether that's on our end or Apple's is TBD)
 
@Pierre Biannic - does it help matters any if you turn off the option to the show the thumbnail bar? (also in Settings / Reader)

There seems to be a weird bug in iOS 16 where having that turned on causes the PDF to constantly scroll back to take snapshots of itself in order to update its preview. (whether that's on our end or Apple's is TBD)
Indeed, after deactivating that option, the page stops jumping. Thanks a lot!
 

plecome

Member
The Cantonese romanization for 蛇 snake is incorrect? Jyutping shows ji4 and corresponding Yale entry as well. In PLC; looks correct in the Cantonese dictionaries. CCY also has a strange entry of "se1u" JP in an alternate definition entry. This is on Android app... There's no bug reporting thread in that forum.
 
Top