User dictionary import crashes / won't recognize input file



I tried to import @simon_crosby's large ChatCPT dictionary text file (see post), which looks like a Pleco 3.2 Legacy dictionary text file, into a new User dict in the Pleco .18 beta, and I ran into the following issues:
  • With the input text format set to "Pleco", a dictionary of 18,500 empty entries resulted:


  • I then changed the input text format to "delimited text", after which I could see some example text for each field in the Import pane, but only 10,449 dictionary entries were recognized, and the ensuing import crashed the beta at the end of the import. After re-launching Pleco, the userdict was still empty.

The input text file lacked the pinyin for the very first dictionary entry, but after filling it in manually, it turned out that wasn't the cause.

Another small issue: When I accidentally tapped the input text format "custom regex", I was ejected from the Import screen and needed to select the input file again.

The 10,449th line in the input text file didn't look suspicious to me.

The "Sample Text" preview option didn't show any sample text.

Hope this proves useful.




Staff member
Most of this was reproducible, but I'm not seeing this issue with empty entries, even testing against the release version of .18 - they seem to come through fine. Do you maybe have a backup of that user database with empty entries, or can you create another one?