Making New Flash Card: Entry Vanishes When Pressing 'Save'

I usually make flash cards and I am quite sure this is not supposed to happen, perhaps there is a bug? This has happened 2 or 3 times so I thought I would share this time to figure out what is going on.

Example:

I get the details of a new flash card ready, then I tap save in top right...
IMG_0630.PNG


Next, I usually see the new flash card entry here at the top, and I can then save it. But it does not appear/register.
IMG_0632.PNG

If there are any developers curious - I have made a screen recording. But esentially it is not much clearer than these 2 screenshots.

Many thanks
 

mikelove

皇帝
Staff member
That normally happens because you were searching for a particular word and then created a user dictionary entry for it; it wouldn't happen if you created a new user dictionary entry from an empty search box.
 
That normally happens because you were searching for a particular word and then created a user dictionary entry for it; it wouldn't happen if you created a new user dictionary entry from an empty search box.
Do you mean by entering a sentence in search and then trying to save it as a card?

Oh wait, so I’m not supposed to make flash cards like that? I have in the past noticed that making a flash card this way was much much easier than starting from scratch and choosing to make a new flash card, as you can see the words listed, check the different meanings and tones. Also, when saving it, then it would automatically have all the tones in (nearly always correct) and the traditional Chinese too, which is unbelievably amazing. I’m unaware of any other way to do all of that so quickly. So I guess I started doing this by default when I noticed I could do that with more ease and less risk of me making mistakes.
 
Last edited:

mikelove

皇帝
Staff member
Do you mean by entering a sentence in search and then trying to save it as a card?

Oh wait, so I’m not supposed to make flash cards like that?
Sorry, no, you *are* supposed to make flashcards like that. It looked from your screenshots like you had not done so. Is that not the case?
 
I pasted a sentence or phrase I want to learn in dictionary search; then a bunch of all the words appear in a list; at the top I selected add to user dictionary, added the English definition in the field and checked everything looks good for a flash card. But then upon pressing save the words in search vanished and I couldn’t see it. Usually the entry I just made would be listed right there for me to add as a flash card.


UPDATE:
I have tried to search the chinese again. The first time I tried this and it didn’t work. Second time I typed from the beginning characters of the chinese sentence rather than a selection from the middle. I found it! Saved it.

So it appears it did save as an entry but the entry didn’t stay visible after, for whatever reason. This happened a few times leading me to think it was unable to save or to make a flash card from
 
Last edited:

mikelove

皇帝
Staff member
So it appears it did save as an entry but the entry didn’t stay visible after, for whatever reason. This happened a few times leading me to think it was unable to save or to make a flash card from
We don't actually do anything to explicitly make sure that the entry you created is visible - we just re-run whatever search you did when you return from that screen, and if that entry is now part of the search results than we show it. So it doesn't sound like anything is working incorrectly here.
 
We don't actually do anything to explicitly make sure that the entry you created is visible - we just re-run whatever search you did when you return from that screen, and if that entry is now part of the search results than we show it. So it doesn't sound like anything is working incorrectly here.
ok lol. It was just confusing that nearly all the other times it was right there after but on a few occasions it seemed it was disappearing. Thanks
 
Top