I can't use pleco

#1
So I dropped my ipod touch 4th gen and the screen smashed and after some deliberation decided to buy a new replacement instead of just getting the screen repaired (which has so far been a mistake).

I got the new ipod (also touch 4th gen) almost a month ago now and loaded all my apps onto it no problem. But when i go to press the add ons button, the ipod just takes me right back to the main page (the ipod home page (sometimes after some strange screen flickerings)). I did a little searching and I saw a post that wasn't my specific issue, but the recommended fix was to uninstall and reinstall pleco, which i decided to try as uninstall reinstall seems to help many computer related issues. Much to my dismay the pleco version I just downloaded is not compatible with my lowly ipod touch 4th gen, so now, not only can i not use the add ons I once purchased, I can also not use Pleco at all.

Is there a way I can install an older version of Pleco AND is there a work around for pleco add ons being retarded?

Thanks so much,
A very unhappy customer
 

mikelove

皇帝
Staff member
#2
Sounds like a combination of two problems:

1) Your new iPod is running a newer version of iOS than the old one - the bug you describe is related to running a very outdated version of Pleco (on an only somewhat outdated OS), one that was probably restored from the backup of your old iPod.

2) Your new iPod is logged in with a different Apple ID than your old one, so it doesn't know about your previous download of Pleco - Apple only lets you install the old version of an app that you previously downloaded.

To fix this, go into the system Settings app / iTunes & App Store, sign out of the account logged in there, reboot the iPod, sign back in with the same email you originally used to download Pleco, then try downloading Pleco again. If that doesn't work, log onto your iTunes account in iTunes on a computer and download Pleco on that - that should enable you to download the old version on your iPod.
 
#3
The second work around I have already tried and believe to be the source of my troubles. How exactly do I download 'the old version' of Pleco? Especially if I can't find my old log-in? -Apple only lets you install the old version of an app that you previously downloaded.-

And, assuming you mean the same version of Pleco that I originally had, doesn't that just run into 'problem one' that you mentioned?
 

mikelove

皇帝
Staff member
#4
That's why you use iTunes on the desktop - you can download the latest version of an app on that (and thus be credited with having downloaded it) even if it's not compatible with your device.

And no, assuming this is the bug I think it is, that version of Pleco was considerably older than the newest version that's compatible with your device.
 
#5
I would like for it to be compatible with my device. There is no way to use Pleco through iTunes that I am aware of and even if there were I would like to be able to use Pleco on my mobile device.

Perhaps we are misunderstanding each other. Even if you are understanding me quite well, I still have not been able to follow your directions to get Pleco onto my device.
Let me explain exactly what I am doing.
I click on iTunes on my desktop on my computer.
iTunes opens and I plug my 4th gen iPod Touch into the computer.
In iTunes I go to my Library and click on the iPod button in the upper right.
In the Apps tab I find Pleco in the scroll menu on the left and {drag it to my ipod on the right/click install}.
I then click Apply in the lower left and get the message "The app 'Pleco' was not installed on the iPod 'My iPod' because it requires a newer version of iPod software."

The above is my problem while the below is what I think you are suggesting to me.

Open iTunes from my desktop on my computer.
Go to iTunes Store > App Store.
Find Pleco and download.
Then go through the steps (3-5) mentioned above to put the app onto the iPod.

If this is indeed what you are suggesting, I had already done this as of posting the thread and get the same error. If this is not what you're suggesting, please be more specific as to what I need to do to get Pleco onto my mobile device.

Thanks
 

mikelove

皇帝
Staff member
#6
Sorry for the confusion.

There's no sync involved here - simply downloading Pleco to iTunes on your desktop will credit your iTunes account with having downloaded it, so that it should then be possible to download the old version of the app directly from the App Store on your device. (Apple only lets you do that if you already "own" the app)

So, now that you've done the first part of that, are you able to download Pleco from the App Store app? If not, check that you're still logged into the same account on your computer that you're logged into on your device.
 
#9
This is a HORRIBLE dumb question, but...please help. I am about to hop on a plane to China. Can I use the features in the $40 bundle with NO DATA plan. i.e. when I ask Pleco to read something or...whatever... is using software installed in my I-phone 5, or something web based. Sorry for the ignorant question. I am very intrigued with this software.
 
Top