Handwriting Data Files Missing

#1
Last night I was using the handwriting recognizer with no problem, but when I tried to use it today I am getting a message saying that the files are missing. I have not deleted any files though and they were originally installed to the RAM not the card, how can I solve this problem without reloading everything and losing all of my flashcard lists, etc. ?
 

mikelove

皇帝
Staff member
#2
That's odd... what type/model of Palm are you using?

You won't need to delete all of your flashcards etc to reinstall the files; just download the "manual install" version (Basic or Complete, it doesn't matter) of PlecoDict from http://www.pleco.com/palmdownload.html, open up the downloaded archive, double-click on each file in the "Handwriting Recognizer" folder, and HotSync your Palm - that should get the data files back to where they're supposed to be.
 
#3
I am using a Palm TX. Last night the browser froze up (happens often), and I had to do a reset, not the full reset that deletes everything though. Maybe this caused some problems. I am downloading the manual install files right now, let you know if that doesn't work.
 
#4
Same thing. Files missing

Yeah. I've had the same problem 3 times now. I have a Treo 650. It says that it is unable to locate the Handwriting files. Reinstalling PlecoDict HWR Database.pdb fixes the problem. I haven't really worked out a pattern yet.
 

mikelove

皇帝
Staff member
#5
Hmm... we have yet to see this problem on a test system here, but enough people are reporting it that it bears watching. Would you mind doing a quick little test for us? Install a copy of FileZ (a file manager utility, free at http://www.nosleep.net/) on your Palm, and the next time you see the handwriting recognizer file disappear, open FileZ, tap on the "View and Edit Files" button, and scroll through the list of files in "Internal" to see if PlecoDict HWR Database is still in there. If it's not, let us know; if it is, tap on it, press the "Details" button, check to see how large it is and when it was last modified, and let us know that. Hopefully that will shed some light on what's causing this.
 
#6
Missing files

I already have FileZ and checked it when it happened. The Handwriting file was still there and was the same size as the original, abt 1.2MB i think. I didn't pay attention to the last modified date though. Will check next time. After I checked it was still there, I tried handwriting again but tapping on the handwriting icon still said it was unable to locate the file. Was pretty strange since I could locate it using FileZ.
 

mikelove

皇帝
Staff member
#7
That is strange, yeah... here's another thing you can try: after you reinstall the file, run FileZ again, select the file, tap on the Details button, go to the Attr tab, and check the "Read-Only" box. If the file is still there but isn't loading then presumably something has changed about it, so making it Read Only might prevent that change from happening again.
 
#8
will try that

It has happened a few more times. To fix it I locate it using FileZ, then move the HWR database file to my SD card. Then I move the file back again to the Internal memory. After that it runs fine again.

Ok Mike. I have now set the file to Read-Only. I'll see if it happens again.
 

mikelove

皇帝
Staff member
#9
Actually, the fact that moving it to and from the SD card solves the problem already tells us almost exactly where the bug is - it's the same bug that forced us to do that extra update for the TX and Z22. And just as in that case, it's 100% Palm's fault :) Fortunately, though, it's something we should be able to fix quite easily even without getting Hanwang to update their software for us.

Do let us know if the Read-Only flag fixes it, though - that might be a good workaround until we release an update to fix the problem more permanently.
 
#10
followup on missing handwriting file

Well, since I last wrote this is what I have noticed. A few hours after I had selected the file as "Read Only", the file went missing again. Moved it to the SD card and back again. After that it has had no problems since then. It is definitely the longest it has been without the file going missing.
 

mikelove

皇帝
Staff member
#11
Hmm... well if the problem is still happening when the files are Read Only then that pretty much confirms what I said in my previous post; it's a Palm OS bug, but thankfully one that we should be able to work around. Thanks for the follow-up!
 
#12
hi, i'm getting this error too. My palm's battery ran out and then after charging it I resync'd everything but the plecodict handwriting recognition gives me the "cannot find handwriting recognition data" error. I've tried reinstalling and moving the file to the SD card and back doesn't seem to solve it either.
 
#15
I have found one possible source of error and a solution to this problem:

I also just uninstalled and then reinstalled PlecoDict onto my Palm Treo 650. When I reinstalled, the dictionary worked, but said it couldn't find the handwriting recognition files. I re-installed them in RAM, still no luck. Since previously I had had the entire PlecoDict on my expansion card w/ no probs, I uninstalled and reinstalled all files onto my card. Still no luck, but this time, the dictionary opened in unlocked mode. Upon clicking on the PD Unlock file (also left over on my expansion card from before), the dictionary unlocked and the hwr worked!

So, don't know what this means, but for those of you having trouble getting hwr to work after re-installing plecodict, you might want to re-tap on PD Unlock to "re" unlock your dictionary and see if that helps.

Also, I have found that PlecoDict runs just fine when I install all the files on my expansion card (and none in RAM). The only downside to this is that the icon doesn't appear in the main menu, but only in the card menu. But the dictionary itself works fine. The user manual seems to indicate that this isn't possible. Don't know why. :)
 

mikelove

皇帝
Staff member
#16
Well PDUnlock does contain copies of the handwriting recognition data files, so it's not unreasonable that it would get things working again, particularly if you're using the older recognizer that came with the free Oxford Dict upgrade.

We've had a few reports of the software not working correctly on an expansion card, which is why we don't encourage putting it there in the instruction manual - it works fine for most people, but the space savings aren't sufficient to justify the risk of doing it for everyone.
 
#17
I "run" all of PlecoDict from my SD memory card including the flashcards. A third party launcher that I use copies all the files into my Treo 650's main memory and then launches the application. After I finish using PlecoDict, any files that are modified (normally the flashcard file and the user dictionary) are copied back onto the SD memory card.

This means actually I'm not really running PlecoDict directly from the SD memory card because I still need to maintain approximately 5MB RAM free on my Treo 650 otherwise I might run into problems when running some programs "off" of the SD memory card using the third party launcher.

The only thing that this trick solves is that my flashcards, PlecoDict's handwriting recognition, and the user dictionary are only taking up my Treo 650's precious memory when I run PlecoDict and not when I run any other program. This saves me approximately 1.5MB.

Jonny Wang: The 3rd party launcher solves the "icon" problem since it creates a shortcut icon of PlecoDict on my launcher screen.
 

mikelove

皇帝
Staff member
#18
That should work, yes, though it's not something we support/encourage due to the hackiness of it. PD2 should support SD-based flashcards / custom dicts, so then all you'll have to deal with is the handwriting recognizer.
 
#19
Hi,
Just in case for you information.

I witnessed the same problem on my TX. "Hand writting file missing". The files are present in the internal memory.

As I had not time to take of the problem for Three days, I did notting and this mornig the files were found by the software.

If it happens again, I now thanks to this forum that it is possible to "reinstall" the files by moving the file from the Internal memory to SD and back again.

Regards
Alexandre
 
Top