Flashcard set for chinese measure words

#2
Chris.../ all/ mike love,
Thanks for providing the original link.
If you did not,how can I transfer your attachment to m s WORD.?
I want to do an index test.谢谢。
 
#3
Chris.../ all/ mike love,
Thanks for providing the original link.
If you did not,how can I transfer your attachment to m s WORD.?
I want to do an index test.谢谢。
It's a tab-delminated text file so you should be able to easily import it using Excel (or any other spreadsheet application, like LibreOffice / OpenOffice Calc).
Then if you really need it in Word just copy/paste the relevant part of table.
 
#4
Chris; Thanks for the 217 measure words flashcard set, it is exactly what I was looking for.

When I am studying them, sometimes the Measure Word part of the dictionary definition will appear in the first screen, when the word is essentially a measure word (e.g. bei1) and nothing else, which is great. But for words like ben3 for books, the Measure Word info doesn't appear on the initial screen and to see the Measure Word details I have to:

(i) go to Change Dictionary Entry and then
(ii) scroll down (in this particular case) 5 screens to see the Measure Word part of the definition.

This makes it really awkward to review the MW part of the definition when I am reviewing a couple of dozen cards in one session.

I am wondering if there is a way to 'coerce' the PLC dictionary (or another dictionary?) to show the Measure Word part of the definition first, if one exists, either generally or for a specific flashcard set, or whether there is some other technique to let me review the MW definition in the initial screen? I'm using the PLC dictionary as my 'primary'.

I did do a 'Convert To Custom Card' for ben3 where I deleted everything except the last 1/3 of a screen that was the MW part. This is not ideal, as I'd still like to be able to see everything, and it is a bit tedious to do for 216 remaining cards.

I attach a screenshot. Thanks. David
MeasureWordScreenShot.jpg
 
#5
To achieve what you are looking for, you'll need to convert these cards into a (new?) user dictionary and then set the dictionary search order to show the definitions of this user dictionary dictionary first.
 
#6
I've done as you advised, thanks for the fast & useful reply. It works 95%! What happens is that even though I set "David's Measure Words" dictionary at the top of the Manage Dictionaries, with PLC in second place, the PLC dictionary still appears first when I search for, e.g., dang4. This is not a big deal, as I can easily see the "USR" dictionary indicator in the second spot, and select that. But it would be nice to have this elegant and perfect. :) A restart of Pleco doesn't help. Any thoughts? Thanks. Cheers, David
 
#9
That's one of the things I was going to test. Given the source file uses the actual characters with tone marks rather than a tone number, there is a chance that there isn't a perfect pinyin mapping.

(for what it is worth, if I were to import it into my user dictionary, I would have converted all the characters)
 
#10
Ok, everything works for me.

1/ I locked my existing user dictionary (so I wouldn't accidentally make a mess)

2/ Next, I made a new user dictionary called "Measure Words", abbreviated MW

3/ Under settings, manage dicts, I reordered my dictionaries so MW was at the very top

4/ Under the MW dictionary settings, I noticed there is an "import entries" that I never noticed before - so I imported the above text file directly, just to see what would happen. Basically it worked, although a couple of entries were not quite right. Oh, I used the original file. I did not create a full text index (yet)

Then, I went to search for dang4 as the David was doing. The second entry that showed up was 档 (the first being 当). Selecting this entry showed my MW definition first and my PLC dictionary definition second.

So, basically it works as I thought it should work. The user dictionaries can be created from a flashcard import file directly and the import seems to ignore the // category lines in the text file.

There are only two problems with the source file (a) there is an extra tab in the definition field. The import is not bothered by it, but tabs are used as field delimiters and it might cause a problem in the future and (b) line 143 looks like

平方公里 <tab> 平方公裡 <tab> píngfāng gōnglǐ <tab> square kilometer <tab> 地 山地 土地

Which messes up the pin yin pronounciation field for that entry.

Step 4 is a new thing for me. Previously, I would make the flashcards, and then convert them to a user dictionary. One advantage of doing it this way is that missing fields will get filled in, like the Cantonese pronunciations, or the traditional character version (? at least I think it will - this set seems to have no difference between simplified and traditional)

So, let's test that.
- delete the flashcards,
- delete the user dictionary and recreate it.
- import the file with line 143 fixed
- definition source, file only
- store in user dict, on
- fill in missing fields, on
- missing entries, create blank

Oh, when you do the import flashcards, store in user dictionary - make sure your user dictionary is listed and is at the top of the import list
After I am done, I have 217 flash cards all linked to my newly populated user dictionary.

Doing a search for particular measure words always shows my measure word user dictionary first.

(I'm using the iOS version of Pleco)

Hope this helps.

PS: I didn't get things right the first time, nor the second. Make sure every user dictionary you don't want modified is locked while you are importing. Make sure your flash cards are imported into their own unique category. This way, if you need to delete the data and start again, your other data will remain untouched.
 
#11
Hmm, one thing.

I noticed that the flashcards have the traditional headwords added during the import, so 个 gets a [個] added to its entry. However, the user dictionary that was created from this import did not get the traditional headword added.

Now if I import the flashcards without creating a user dictionary entry - and then manually create a user dictionary entry by visiting each entry and , the traditional headword is included in the definition.

@mikelove I think this might be a "bug" during the flash card imports, also create user dictionary step in that the fields that are filled in automatically are not added to the user dictionary.
 

mikelove

皇帝
Staff member
#13
@pdwalker - ah, that would make sense, yes; thanks. (in 4.0 flashcards and user dictionaries are essentially the same thing so this sort of idiosyncracy should hopefully become a thing of the past)
 
#14
Ok, everything works for me.
I'm compiling these useful flashcards. Could you upload your revised flashcard and dictionary as a PQB file here so that new users can benefit from it? I'll include this in my summary post for new users as well. Thanks.
 
Last edited:
#15
Hi agewisdom,

I was looking at what I did, and I think I can improve what I imported slightly. I have a few errors and inconsistencies that I'd like to correct, and then I'll upload the appropriate files here.

Stay tuned!
 
#16
Hi agewisdom,

I was looking at what I did, and I think I can improve what I imported slightly. I have a few errors and inconsistencies that I'd like to correct, and then I'll upload the appropriate files here.

Stay tuned!
Great. Looking forward to it. Thanks in advance for sharing and sparing the rest of us the hard work, trial and error :)
 
#17
Hello, sorry, I'm not terribly cyberliterate. How do I create a dictionary from the flashcard file? When I use the "manage dictionaries" --> "select file", the flashcard file doesn't appear. Does it have to be changed to a .pqb format?
 
#18
Hi mdlevis,

you almost had it, you need to tap on Add User in Manage Dictionaries and then tap on Create New, after which you will be able to name it and Import Entries into it.

Hope this helps,

Shun
 
#20
Hello, sorry, I'm not terribly cyberliterate. How do I create a dictionary from the flashcard file? When I use the "manage dictionaries" --> "select file", the flashcard file doesn't appear. Does it have to be changed to a .pqb format?
If you're not in a hurry, you might consider waiting for @pdwalker to upload a more up-to-date version? Anyways, hope you managed to create the PQB file :)
 
Top