Exported User dictionary entries dont have simplified and traditional

When I export my user dictionary on my phone and import it on my tablet the entries dont come with both traditional and simplified characters. I must choose one or the other based on the encoding language I choose. The original entries on my phone have both character sets but during the export process one is lost. Is there any way around this?
 
Screenshot_20221221-144414_Pleco.jpg
 

Attachments

  • Screenshot_20221221_144658_Pleco.jpg
    Screenshot_20221221_144658_Pleco.jpg
    369.6 KB · Views: 12
  • Screenshot_20221221_144800_Pleco.jpg
    Screenshot_20221221_144800_Pleco.jpg
    921.6 KB · Views: 11
Ok I have solved my problem, if I back up my dictionaries and share them to myself the simplified/traditional problem won't be there. I suppose the only problem now is that if I export from phone I must delete on tablet ans readd it. Any special settings for the dictionary are deleted since it is technically new.
 

Attachments

  • Screenshot_20221221_151733_Pleco.jpg
    Screenshot_20221221_151733_Pleco.jpg
    397.4 KB · Views: 9

mikelove

皇帝
Staff member
You should be able to export in both character sets if you select that option on the export screen; encoding-wise you'd just want to make sure you used UTF-8 so that both come through correctly.
 
I don't see the option to export both. I tried every encoding type while making sure to load it correctly on my other device.
 

Attachments

  • Screenshot_20221221_220715_Pleco.jpg
    Screenshot_20221221_220715_Pleco.jpg
    91.8 KB · Views: 14

mikelove

皇帝
Staff member
That's odd... try this: export some flashcards (doesn't matter which) with the character set in that export to do both character sets, then try exporting the user dictionary again; does that work any better?
 
These aren't flash cards, they are dictionary entries for a user dictionary I made. I am not seeing any place to change the character sets in the export area of the dictionary settings.
 
Ok judging by how the txt looks it is exporting both sets now. Could the problem have been because I normally have the Ankidroid flashcard system enabled for pleco? I turned anki flash cards back on and exported again and it seems to have exported both again.
 

mikelove

皇帝
Staff member
Possibly, yeah - if I remember correctly it's supposed to always export both character sets, but somehow it's inheriting whatever the last flashcard setting is for that instead.
 
Top