Dictionary History does not save search results



The Dictionary History button on my Pleco Android app doesn't actually save or show the words that I've searched in the Pleco dictionary.

I use the dictionary search quite a lot each day and out of every 300 searches, it maybe saves 1.

Also the one word it saves is often a very easy word like 一 because I accidentally entered 一 at the front of a character I was trying to look up while entering the character via the handwriting function (Chinese to English).

But entering the word via the keyboard doesn't seem to get saved by the History function either (English to Chinese). My live and still OCR function has a lot of trouble staying still and recognising characters, so I've stopped using it, but History has never saved any words looked up via that method either.

It's a bit of a bummer because I'd like to review the words I've looked up and also perhaps choose which ones I'd like to add to my Pleco flashcards at the end of the day.

Is there a setting I'm missing that could get History to work? From memory, the History function has never really worked on my Pleco.

Thanks for any time and assistance provided!


Staff member
Yikes, sorry about that. What model of phone do you have and what versions of Android and of Pleco are you using?


That's OK, I think maybe I've got something set up incorrectly because based on the forums it seems to work for other people.

I'm on a Samsung Note 8 running Android version 9. My Pleco version is 3.2.72.


Oh! I think I've figured out what I'm doing wrong (embarrassed)!

I was just about to post a screenshot and just noticed there are tabs at the top of the history pane and mine was set to OCR the whole time (which struggles on my device). When I clicked Dict, I found my searches.

How embarrassing! Thanks for letting me talk through my problem here though! I would have never seen those tabs had I not tried to post a screenshot.