cantonese text to speech delay

yee

秀才
I recently noticed something. After starting pleco, the first time that text-to-speech is tried, there is about a 20 second delay. During this time, pleco is frozen, like it is stuck waiting for something. After the first time, the speech shows no delay.

I have purchased all the voices. I am alternating between male cantonese and female cantonese (Kayan & Kaho).
Android Pleco 3.2.77
Motorola XT1670
Android 8.1.0
Ekho TTS Cantonese

Why is this the case?
 

yee

秀才
I THINK it with Kayan & Kaho. The quality of the voice (male alternating with female) is very high when it comes out 20 second delay.

I have installed Ekho. If I'm not mistaken, the voice is very mechanical.

Preferred gender : alternating
Preferred gender (Cantonese) alternating

Checked off:
Use TTS if no recording
Use Cantonese TTS if no rec...
Use Cantonese in popup/OC..

Female TTS Voice : system Mandarin Female ....No female Cantonese is a choice. :(
Male TTS Voce: Cycle Voices

Not checked : Hide headword audio

System TTS Engine : Ekho TTS Cantonese
System TTS Settings : configure system TTS setting (Ekho in menu)

TTS voices (Cycle voices)
Kayan, Kaho, Sstem Cantonese Female checked

Not checked:
Hide example button
Enable English

recorded mandarin audio volume: 100%
recorded Cantonese audio volume: 100%
pleco TTS volume : 100%
system TTS volume :100%

Voice recognition language : cantonese
 
Last edited:

mikelove

皇帝
Staff member
Does it help if you uncheck System Cantonese Female? What about if you also uncheck Kaho and just leave Kayan?
 

yee

秀才
Interesting.

Just having Kayan, once I got a message that Pleco frozen or something, once 10 sec. Mostly about 20 sec delay.
Just having Kaho, I consistently got about 20 sec delay

However, under ALL circumstances, I have what appears to be one male voice and one female voice alternating. If I'm not mistaken, its a bit more mechanical than usual (but I'm not sure).

Note, this delay is ONLY with the first use of voice after restarting Pleco. Once something loads up, each subsequent use is without delay.
 
Last edited:

mikelove

皇帝
Staff member
Hmm... might be a file access issue; are you using the 'enhanced' data for these voices? Could you try deleting that and just using the basic data instead? Also, are these stored in internal memory or on an SD card?
 

yee

秀才
Nothing is stored on SD card.

I have no idea what "enhanced data" is but a quick google search suggests it has something to do with a data plan. My phone does NOT have a data plan at all. It is prepaid text/phone only. Anything else is wifi. How does one manage "enhanced data"?

Could Pleco be timing out on trying to use data through my carrier? I didn't have this issue before even with a prior phone.

All I did was install the basic Pleco, put in the license code and let Pleco download all the libraries, dictionaries, voices via WiFi. I do remember having a stack of the downloads fail for some reason and then I restarted the download manually a few hours later.

My license is supposed to have all the extras as a package (purchased 3-5 years ago ~$60-70). I'm pretty sure I also purchased licenses for a few dictionaries and/or extra features about a year afterwards but I don't remember; I seem to remember making the 2nd purchase when something came out which was useful for Cantonese.
 

mikelove

皇帝
Staff member
Sorry, I mean the enhanced text-to-speech data files. Check "Add-ons" / Installed, delete all of your TTS add-on downloads, reboot your phone, then just download the basic Kayan / Kaho - does that get things to load faster?
 

yee

秀才
Definitely on the right track.

Problem improved with deleting / reinstalling TTS. However, other problems starting cropping up. There was no correlation with voices heard and TTS settings. Eventually ALL TTS lost.

I reinstalled everything from scratch. Kayo/Kayan seems to work with a 4-5 second delay on first use only. I can live with it but would love to know why.
 
Last edited:

yee

秀才
The problem is a regression that happened some time between
plecodroid-190426.apk (circa Sept 7, 2019) and
plecodroid-210117-website.apk (circa April 19, 2021)
 

mikelove

皇帝
Staff member
We did update the TTS libraries between those two releases - had to to comply with Google’s 64 bit requirement - but we haven’t had any other complaints about this as far as we know. It may just be an incompatibility of some sort with your phone, unfortunately.
 

yee

秀才
Further experimentation shows a possible cause of the delay.

I had the delay when I had only Kayan and Kaho Cantonese voices loaded. I am using Cantonese exclusively.

I think the delay disappears when I added Hui & Liang Mandarin voices.

Is Pleco searching for the presence of Mandarin TTS before settling on Kayan/Kaho?
 

mikelove

皇帝
Staff member
It might be that it’s searching for a built in Mandarin TTS when those are not installed but skipping that search when they are installed - does it help if you set the System TTS Engine to “None?”
 

yee

秀才
No change. The presence of a Mandarin TTS is needed to avoid the delay (with or without System TTS).
 
Top