Adding user dictionaries?

#1
Hello!
Is there a way to add user dictionaries in full version of Pleco?
Pleco is the only application that has fullscreen handwriting (bite me if that's not correct), and that would be really cool to use dictionaries on other languages, Chinese-Russian, for example.
I am using StarDict version of BKRS.info Chinese-Russian dictionary for couple of years, it is the best Chinese-Russian dict at the moment. And it is free. Developers allow everyone to use it anywhere.


If adding user dictionaries is not possible, may be developers of Pleco can add this dictionary as a free addon? http://bkrs.info provides several dict formats, may be one of them is able to be converted to pleco format. Even if no, we can ask bkrs.info developer to give you raw dump of the database.
 

mikelove

皇帝
Staff member
#2
Yes, you can add a user dictionary if you've purchased the Flashcard System add-on module. Tough there's no full-text search support in them at the moment, so while Chinese-to-Russian should be quite doable Russian-Chinese is somewhat trickier.

Anyway, all you'd need to do is take the text file version of the dictionary and format it like this, one entry per line:

headword<tab>pinyin<tab>definition

Pinyin should be with tone numbers instead of marks (ni3 e.g.), headword can be simplified or traditional or, if you want to use both, simplified[traditional] .

We could certainly consider making this an official add-on if it's popular and it's copyright status is clear - we've got a few other items in the free adaptation queue that we need to get out too at some point (like Soothill's Buddhist terms dictionary) so it wouldn't be difficult to add one more.
 
#3
headword<tab>pinyin<tab>definition
What should that look like if my entries have Jyutping instead of pinyin?
E.g., I'm guessing or hoping for: headword<tab>{jyutping}<tab>definition

EDIT: My guess seems to be right. Importing a text file with just this line

我<tab>{ngo5}<tab>I

works fine. When I go to settings and enable the display of pinyin, and go to this user dictionary and this entry, it simply does not show "PY wo3"; it doesn't leave a blank space either, simply showing "JP ngo5" in that space. This is the exact behavior desired. The other dictionaries show:
PY wo3
JP ngo5
as usual.

I see that the thread is old, but I don't think the manual answers this question, either under Dictionaries or Flashcards. Now a little time with Excel...

EDIT2: That entry formatted as above works as a flashcard too. Just set Flashcards/New Test/Display/Primary Pronunciation to Cantonese.
 
Last edited:

mikelove

皇帝
Staff member
#4
That's odd, user dictionaries don't support Cantonese yet - any chance you've enabled the option to auto-generate Cantonese for words that are missing it? Or that you were viewing that in the same screen as an entry from another dictionary that includes Cantonese?
 
#5
Oh? Yes, auto-generate was on. With auto-generate off, the user dictionary does not work as above but the flashcard still shows ngo5. [Fill in missing fields is off, and I know it's mine because I put ngo6 in there to test this.]

To anyone interested: Leaving the curly braces off and telling Pleco that ngo5 is pinyin does not work. :)
 
Last edited:
Top