Help Needed with Enabling Tags in Pop-Up Definitions

kasim

举人
Hello everyone,

I'm currently having trouble with the pop-up definitions in Pleco. While the dictionary displays tags properly(dictionary_search.jpg), these tags don't appear in the pop-up definitions(difference between me_popup.png and shun_popup.png). I've seen it work correctly in screenshots provided by others(Shun), but even after I asked him we couldn't figure out the specific setting that needs to be enabled.

Has anyone encountered this issue before? Could you guide me on what settings might need to be adjusted to enable tags in the pop-up definitions? Any help would be greatly appreciated!

Thank you in advance!
 

Attachments

  • me_popup.PNG
    me_popup.PNG
    774.9 KB · Views: 84
  • settings.png
    settings.png
    55.5 KB · Views: 84
  • Shun_popup.PNG
    Shun_popup.PNG
    267.1 KB · Views: 85
  • tags_added.png
    tags_added.png
    25.6 KB · Views: 86
  • dictionary_search.jpg
    dictionary_search.jpg
    267.1 KB · Views: 84

mikelove

皇帝
Staff member
It doesn't look like there's a [] around the + at the top of that first popup screen - maybe it wasn't added to flashcards yet? Do you have a paid copy of the flashcard add-on? (this sort of behavior can be very unreliable otherwise)
 

kasim

举人
It doesn't look like there's a [] around the + at the top of that first popup screen - maybe it wasn't added to flashcards yet? Do you have a paid copy of the flashcard add-on? (this sort of behavior can be very unreliable otherwise)

I have set tags on the flashcards that are embedded in Pleco, 'HSK 3.0', I did not add anything manually.
As for the paid copy, I bought the Professional bundle for 400RMB or sth, so I think it should be included.

I also wanted to ask was the Outlier dictionary removed from Beta? My friend can see it on Legacy version, but on the Beta I cannot see the option to buy it anywhere. I have downloaded all dicts, but it doesn't seem to be there. Attaching pictures
 

Attachments

  • Beta_dictmgmnt2.jpg
    Beta_dictmgmnt2.jpg
    184.8 KB · Views: 78
  • Beta.jpg
    Beta.jpg
    216.3 KB · Views: 81
  • Legacy.jpg
    Legacy.jpg
    521.1 KB · Views: 79
  • Beta_dictmgmnt.jpg
    Beta_dictmgmnt.jpg
    202.5 KB · Views: 81

mikelove

皇帝
Staff member
Does it make any difference if you turn off the 'bold text' accessibility option? And if you tap on the + button with 规定 selected in the reader, what happens?

We aren't able to do in-app purchases in the beta and yet we also aren't allowed to link to any other purchase options due to Apple restrictions (which they enforce even on betas); you can buy add-ons in our website store at store.pleco.com.
 

kasim

举人
Does it make any difference if you turn off the 'bold text' accessibility option? And if you tap on the + button with 规定 selected in the reader, what happens?
I tried to turn off the bold text in iphone accessibility settings, still the same, the tags do not display. Is there any embedded setting within Pleco that needs to be turned on to display tags.

Tapping on + button and adding it to the flashcards manually also does not help, see the attached video.


The tags are still displayed when searching words individually in the dictionary, however in Reader pop-up definitions, they are not visible.
 

Attachments

  • IMG_2106.PNG
    IMG_2106.PNG
    774.9 KB · Views: 75
  • IMG_2122.PNG
    IMG_2122.PNG
    551.4 KB · Views: 76
Last edited:

mikelove

皇帝
Staff member
Can you email me a copy of this specific PDF? The fact that even tapping + is not causing the flashcard to be added correctly suggests that there's something strange going on with the PDF text - 规定 seems to be matching against dictionary entries correctly but failing to match against the flashcard database.
 

kasim

举人
I really do not think it is caused only by the specific PDF, because even when I open some text from the keyboard containing the testing word 规定, it does not show the tag in the pop-up definition.(See attached screenshot).

I will e-mail you the PDF and my user settings, it seems like there has to be some function not enabled that is preventing the tag from being visible, because it works just fine for Shun, but we both did not find the reason why it does not work on my devices(both iPad and iPhone)
 

Attachments

  • Reader clipboard.PNG
    Reader clipboard.PNG
    434.6 KB · Views: 84
Last edited:

mikelove

皇帝
Staff member
Another thought: did you turn on the 'exclude from reader' option for your flashcard database in Settings / Manage Dictionaries? That would prevent the tags (and + icon) from appearing.
 

kasim

举人
Another thought: did you turn on the 'exclude from reader' option for your flashcard database in Settings / Manage Dictionaries? That would prevent the tags (and + icon) from appearing
Yes! This was it. Tags are displayed now, thanks a lot for your help!
 

Shun

状元
Hello Mike,

could one perhaps further improve the WORDS tab's word lists by automatically displaying the colored tags for any words that are already in Flashcards? Right now, a [+] square is visible in light gray at the right:

IMG_7776.png


The colored tags could be placed to the left of the dictionary abbreviation at the top of each line (right-aligned). The CPU requirements shouldn't be that great since far from all the words in the WORDS tab are usually already in the flashcards database. If you like the idea, might this be addable as an off-by-default option?

Many thanks, Shun
 

mikelove

皇帝
Staff member
Thanks!

This is doable on iPad, we've previously experimented with it on iPhone and tend to think it's too cramped. Then again, one thing people have been fairly consistent about is that they're totally fine with cramped, ugly UI if it gives them more information density, so if it is in fact off by default then there's not really any harm to supporting it on both.

I'd have to check whether bringing over the code for that from the reader is simple enough that it might be manageable for 4.0.
 
Top