TTS not used for headwords

Discussion in 'Pleco for Android' started by , Jun 17, 2017.

  1. 澳

    举人

    Hi, I've been wanting to use the new TTS for headword pronunciation. I checked the selection in audio options to use TTS if no recordings found, and deleted the audio pronunciation files. However now when I tap the headword pronunciation icon no sound is made. Perhaps a bug? Or am I doing something wrong?

    Cheers
     
  2. mikelove

    mikelove 皇帝 Staff Member

    Is the TTS actually installed? (does it show up as an option in the Sentence portion of Settings / Audio?) Can you listen to sentences with it? Any chance your device might be muted or have its volume turned down?
     
  3. 澳

    举人

    Yes, I just purchased the new yafang TTS and installed it. Example sentences work fine. Volume is up. TTS for English headwords works fine just silence for Chinese headwords
     
  4. mikelove

    mikelove 皇帝 Staff Member

    Hmm, so just to confirm, you have only the Yafang TTS add-on installed and not any others? Have you also deleted our audio recording add-ons? Which system TTS engine is selected in Settings / Audio?
     
  5. 澳

    举人

    I've attached some screenshots to help. When I use "None" or "Pico TTS" there is silence for the headwords. The other two options are inbuilt into my xiaomi phone and while work for headwords it is using xiaomis TTS, not the yafang like I wish. Apart from yafang no other audio files installed on pleco.
     
  6. mikelove

    mikelove 皇帝 Staff Member

    Any chance that Pleco is configured to primarily use simplified instead of traditional characters? (looks like there's an obscure bug that can keep Yafang from working in that case)
     
  7. 澳

    举人

    Yep, that fixed it. Wouldn't have thought to do that
     

Share This Page