Feature Request: Option to disable Audio output

#1
As the title suggests. I work in a library a lot, and sometimes accidentally hit the speaker button next to the headword pinyin.
I never ever use the audio function (on purpose, that is).
Could a setting be implemented to completely disable audio playback? Or that basic audio functionality has to be installed as an addon, like those available for purchase?
 

mikelove

皇帝
Staff member
#2
Switch Pleco's "Text to speech engine" in Settings / Audio to something that doesn't support Chinese - the Svox one built into many/most Android devices qualifies, I believe, as do a number of free ones on Play (IVONA for example). Assuming you've also deleted the audio database files in Add-ons / Installed, that will give you a setup with no audio.
 
#3
Switch Pleco's "Text to speech engine" in Settings / Audio to something that doesn't support Chinese - the Svox one built into many/most Android devices qualifies, I believe, as do a number of free ones on Play (IVONA for example).
When I go to Settings / Audio, the only options I see are Hardware Audio (Preferred Gender and Preferred Gender Cantonese) and Speech-to-Text. There is no option for text to speech, neither on my phone nor in arc welder.
 

mikelove

皇帝
Staff member
#4
Ah, in that case just go into Add-ons / Installed and delete the audio modules and that should get rid of the icons.
 

mikelove

皇帝
Staff member
#6
They come in the basic files package, actually - some parts of that are revealed in Add-ons so that people can delete or update them.
 
#7
Hello Mike,

I think I am using the latest version of Pleco on my iPad. Version 3.2.14. As I understand it, this dictionary works perfectly as a Mandarin (Audio) dictionary. ie. you press those Audio symbols that looks like a speaker or a handheld loud speaker symbol, next to Words or phrases , even sentences, and you get the Mandarin Audio. If a speaker is present after the Cantonese Yuet Ping, the audio or speaker also works. No problems, you get the equivalent Cantonese sounds. Thanks a lot!

I have noticed that you can change a switch in SETTINGS under AUDIO, and the default readings in the READER changes to Cantonese sounds instead of the Mandarin sounds. While this is kind of nice why can't a similar switch be found in the READER itself, to turn the sounds to Cantonese, and then reversing the same switch turns it back to the default Mandarin sounds without going to Settings again.

I mean since you have taken the trouble to add Yuet Ping transliteration speakers, to the already plenty of Mandarin Pinyin speakers, and the former produces pretty good Cantonese sounds, the "final upgrade" would be to provide both types of sounds in the Reader after just highlighting or selection.

But the working of the switch in the Settings under audio is rather confusing. Sometimes after changing to Cantonese for Audio, it is not possible to get back to the default Mandarin sounds ! ! I have to RESET ALL, before getting back to the "normal " Mandarin Audio Dictionary default. Maybe I don't really understand this switch.

Well hope I haven't bore you. This Pleco started off as an excellent CE-EC Mandarin sounds Dictionary. Then you started adding Yuet Ping. I was just too amazed I could make it read out in Cantonese! But the switch is a bit awkward. Anyway this is not important. Just a suggestion for the future perhaps. You can make it read out in either Mandarin or Cantonese!

Thanks.

Shuan
 

mikelove

皇帝
Staff member
#8
You can toggle between Cantonese and Mandarin audio in the reader by long-pressing the audio button - no need to go into settings.
 
#9
You can toggle between Cantonese and Mandarin audio in the reader by long-pressing the audio button - no need to go into settings.
Oh ! That is truly remarkable. Wouldn't have thought holding longer changes the reading to Cantonese sounds.
Just to confirm here, no need to change any variable in the settings. Just hold the loud- speaker symbol longer.
In that case I would suggest you add a 'status' button indicating either putong/canton, to make it obvious.
After all you've made so much effort to be BI-lingual and this is a dictionary even for the uninitiated.

I am buying another copy on the Android platform. I really like the READER.
Thanks again.
 
#11
I've deleted all audio pronounciation add on but there is still audio button on the head word. Also there no option to set the audio volume to 0% in pleco settings (10% is the lowest).

It would be nice if there is an option to disable all audio in pleco.
 

mikelove

皇帝
Staff member
#14
Ah, sorry, forgot that we recently added built-in audio recording files to our APK. No way to hide those at the moment but we can consider adding a checkbox for that in a future update if it's annoying people. (on iOS since 2013 there's never been an option to hide audio in the headword and I don't know if there's been a single complaint about it)
 
#15
It would definitely be nice to have the option to disable audio for headwords - I've had similar problems when using pleco in the library, as have many of may classmates.
 
#16
I dont seem to be able to change the headword audio in flashcards from Cantonese to Mandarin. I've searched everywhere but cannot find the solution. In the Headword audio i only have an option for Cantonese, but in the Sentence audio i can choose Cantonese or Mandarin. Any ideas?

thanks
 

mikelove

皇帝
Staff member
#19
Ah, sorry, missed the fact that this was flashcards. This will be fixed in 4.0, it's a relic of our current flashcard system not really being designed around Cantonese :) (really, if you look in the database file you'll see Cantonese awkwardly wedged into another column called 'altdictrefs' because it was easier for us to repurpose that field than to go back and alter the schema to add a new Cantonese one)
 
Top